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1 Glossary 
 

Message A text message sent to a Cellular/Mobile phone, Beeper or Pager. 

Group A list of recipients that are associated together under a single group name. This facilitates sending 
messages to multiple recipients quickly and simply.  

Rota A list of recipients and associated ’on’ and ‘off’ times and dates. This allows a message to be sent to a 
Rota and for the software to identify the appropriate recipient(s) for that time and day.  

Subscriber Number A Subscriber Number is the number used to uniquely identify a particular pager. The Subscriber Number 
frequently, but not always, consists of 6 digits. Subscriber Numbers only contain numerical digits. 

Callsign Some pagers can be addressed with a Callsign, such as “FRED99”, which is easier to remember than a 
Subscriber Number. Callsigns always start with a letter and end with a digit and can be up to ten 
characters long. 

Pager ID A pager ID is used to refer to either a Subscriber Number or a Callsign. 

ODBC Microsoft’s uniform database connectivity technology. (Open DataBase Connectivity). 

2 Introduction 
It is intended for use by System Managers – that is those of us who have to install and maintain the system. The 

information is sometimes of a technical nature. Configuration of the Client software is dealt with in the User 
Guide whilst all installation details can be found in the Installation Guide. 

Your comments on this Guide are solicited.  The more feedback you provide, the better the product can become.  
There is a “Feedback Form” on page 43 or you can email support@csoft.co.uk with comments.  

mailto:support@csoft.co.uk
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3 What is the Messaging System? 
The Messaging System lets people in the office send textual messages from their computer to cellular/mobile phones 

and beepers/pagers quickly, simply and efficiently.  

With this system you only need one modem or Internet connection for your whole company. Messages are composed 
on each user’s PC, sent over the corporate network to a central Server. The server processes the message where 
necessary and then sends its directly to the Service Provider who transmits it to the recipient’s wherever they 
may be. 

It is  

♦ Fast 
♦ Efficient 
♦ Simple to use 
♦ Cost Effective  
♦ Well supported to ensure that it works the way you want it to 
 

It is feature rich, offering 

♦ Messages that can be automatically repeated until the recipient acknowledges receipt – to make sure that 
messages get through. 

♦ Groups of users that can be defined and then contacted with a single address – e.g. SALES. 
♦ Rotas that can be defined to reach different people at different times of the day or week – e.g. SECURITY. 
♦ Interconnectivity with other programs. Applications can drop messages into a shared network directory for 

automatic transmission. 
♦ Corporate, Departmental and Private Address Books. 
♦ Detailed logs of all transactions. 
♦ A highly degree of configuration in terms of how it handles messages. 
♦ Licensing for 5, 50 or 500 users on your network. 
♦ Client-Server connectivity over TCP/IP and IPX/SPX networks. 
♦ Operating system flexibility; whilst the Server runs only under Windows NT 4.0, Client programs can run under 

Windows 95, 98 or NT 4.0. 
♦ Backup routes that can be defined to cover the unlikely failure of a telephone line or Internet connection. 
♦ Support. We offer a high degree of expertise to ensure that it works the way you want it to. 
♦ Redundancy and scaleability. Multiple servers can be supported. 

4 What does it consist of? 
♦ A Client program that runs on a user’s PC to permit you to send messages. The Client sends messages to one or 

more Servers for onward transmission. 
♦ A Server program running on a dedicated PC that delivers services to a group of users on a network.  
♦ An InfoLink Receiver and cable to enable the Server to receive Messages. The Server program supports “Reply 

Requested” messaging whereby a recipient of a Message must acknowledge receipt of the Message by sending 
another Message to a dedicated receiver attached to the Server. If the Message is not acknowledged then the 
Message is re-sent. 

♦ A Licence to permit multiple users. When initially supplied for evaluation, only one user is supported. Licences 
can be upgraded in minutes. 
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5 Server Installation 
 

The server installation is described in full in the Installation Guide. This in located in the Docs directory of the CD-
ROM or under your chosen installation directory once you have installed the server.
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6 Server Configuration 

6.1 Running the Server 
As a precaution reboot your Server at this stage. 

Log in as the person who will be the System Manager. This is very important the first time the system is run, since 
the person performing the installation will be granted System Manager authority. 

The Server should start automatically. 

Don’t worry if you get the error “Infolink Receiver not found”. You can easily fix that, as explained next. 

6.2 Configuring the Server for the Infolink Receiver  
 

Before configuring the Infolink Receiver, make sure you know at least: 

 

• Which COM port the receiver is connected to. 

• The Subscriber Number for the receiver 

 

From the File menu, choose Options; select the Infolink Receiver tab. 

If you received the “Infolink Receiver not found” error, change the COM port setting to match the COM port that 
you connected the Infolink Receiver to.  

Set the subscriber number. This is the Telephone number that users call to send Replies back to your server. Insert 
the Subscriber Number allocated to your Infolink Receiver. The person who supplied the system will tell you the 
Subscriber Number allocated to your Infolink receiver. 

 

The Subscriber Number is added to all messages that are marked as “Reply Requested” to indicate to the recipient 
what number to call, to send an acknowledgement. Thus a message “Please call the office” will be sent as 

RR 01523000000 0123 Please call the office 
 
♦ RR indicates that this is a Reply Requested Message 
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♦ 01523000000 will be set to the Subscriber Number of your Infolink Receiver and is the telephone number that 
the recipient must call to Reply to the Message. 

♦ 0123 is a Message Sequence Number that is different for each Reply Requested Message that is sent. The 
recipient sends this number when they call the above number. In practice, the recipient dials the phone number 
indicated and listens to the prompts. They then enter the Message Sequence Number followed by “#1” to send 
the Reply. In this example that would be  0123#1 

The “No of Retries” entry controls how many times a message will be sent if no Reply is received from the recipient. 

The “Timeout” entry controls the interval between repeat transmissions. 

When you have finished press  “OK” and the new details will be saved and come into effect straight away. 

6.3 Drop Directory 
The Drop directory is used by the Server to collect Message requests from non-Client applications.  Sending a 

Message using the drop directory is a ‘drop and forget’ method of sending Message requests.  You will not 
receive any replies to a Message request issued from the drop directory. 

 

By default the Drop directory will be set to; 

 

C:\WINNT\Profiles\<system administrator user name>\drop 

 

If you wish, change the Drop Directory. From the menu File->Options screen, select the “Drop Directory” tab. 

 

 

You can enter the path to the “Drop directory” or you can press the “Browse” button and navigate to the location of 
the “Drop Directory”. Note that if the directory you select does not exist, it will not be created. 

 

NOTE:  The drop directory should also be available as a network share for client applications. See the Windows 
Help for details of how to do this. 

 

The Drop-file format is explained in the User Guide.  
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6.4 Configuring Output Routes 
An output route defines what device and protocol will be used to send a Message request to a Service Provider. 

The system can be configured for every available device that exists on the machine upon which the server has been 
installed. The following device types are currently supported: 

! Modem (dial-up) 

! Network (Intranet/Internet) 

! Serial 

! DTMF 

 

6.4.1 Configuring Devices 
Before a device can be configured for use within the Server, it must be installed and configured on the machine upon 

which the Server runs. 

To load the device list, select ‘Edit->Device Outputs’. The Device Outputs screen will then load 

 

To add a new device press the “New…” button this will then load a blank “Device Properties” screen. 
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When you have finished creating a device press the “OK” button.  The new details will then be saved. 

When you have finished defining output types the system will need to made aware of these new device types, this is 
done by pressing the “Update” button. 

6.4.1.1 Configuring a Modem Device 
A Modem Device is an internal or external modem fitted in or to the Server.   

Modems should be installed and configured according to the installation manual for the particular modem before 
attempting to configure the device within the system. 

It is very important that you use the latest Modem Drivers with your modem. Be sure to visit the Modem 
manufacturer’s website to download the latest modem drivers.  Not having the latest drivers correctly installed 
on your computer will probably cause problems. This is the single most common problem experienced when 
installing the Server. Please save yourself time by getting and installing the correct driver for your modem. 
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To configure a modem device  

! Enter a “Name” for the device  

! Select its device type 

! Select the name of the modem to be used by this device 

When you have finished press the “OK” button. 
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6.4.1.2 Configuring a Network Device 
A Network Device is an Intranet/Internet connection to a Service Provider. 

An Intranet/Internet should already be configured before you attempt to configure the network device. 

 

 
To configure a network device  

! Enter a “Name” for the device  

! Select its device type 

When you have finished press the “OK” button. 
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6.4.1.3 Configuring a Serial Device 
A Serial Device is either a Leased line or permanent serial connection to a Service Provider. 

COM ports should already be fitted and configured before you attempt to configure the device within the system. 

 
To configure a network device  

! Enter a “Name” for the device  

! Select its device type 

! Select the “Port” 

! Select the “Baud Rate” 

! Select the Databits to be used 

! Select the Stopbits 

! Select the Parity 

 

When you have finished press the “OK” button. 
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6.4.2 Configuring Service Providers 
The Server needs to know the available routes and protocols for a service provider. 

To load the list of Service Providers, select “Edit”->Providers. The Service Provider screen will then load. If no 
providers have been defined yet, and your installation does not come with one configured, you will receive a 
warning that “There are no Service Providers Defined”. Click “OK” on this warning. 

Some distributions are installed with one Service Provider defined (such PageLinkII) whilst others will not have any 
service providers at start-up. If your service providers are not defined, then you will need to create entries for them 
prior to creating/assigning output routes. 

  

 

To create a new Service Provider, select the “New...” button. Enter the Name for the Service Provider and tick the 
check box if this is the Default Provider. Click “OK” and the new Service Provider will appear in the list now. 
Repeat this for all of the Service Providers you need to Specify.  
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6.4.3 Configuring Service Provider Routes 
To create new output routes for the Service Provider select their name in the list and then press the “Properties” 

button.  This will then load the “Service Provider Properties” screen. 

 

The “Service Provider Properties” screen allows you to specify the output routes for a service provider 

 

 

To add a new output route, press the “New…” button this will then load the “Route Details” screen.  This will then 
allow you to specify the details of the output route. 

When you have finished specifying details for a Service Provider, press the “OK” button.  If you have created, 
amended or deleted details for a Service Provider you will be asked if you wish to update the Service Provider 
routing information.  If you click the “YES” button the system be informed of the new changes 

6.4.3.1 Configuring the Route 

6.4.3.1.1 Modem Device type 
To set up a modem route correctly  

 

! Select the modem device to be used 

! Select the Protocol (this defaults to TAP which is most common, but your Service Provider can tell you which 
Protocol to use) 

! Enter the Phone Number for the service provider 

! Enter your password for this Service Provider route. This is not always required and your Service Provider can 
supply this information. 
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When you have completed the route press the “OK” button 

6.4.3.1.2 Network Device Type 
To set up a network route correctly; 

! Select the Connection to be used 

! Select the Protocol (this is SNPP by default, but your Service Provider can tell you which Protocol you should 
use). 

! Enter the Primary IP address to be used. (Ask your Service Provider for this information, sometimes referred to 
as the TCP/IP address). 

! Enter the Secondary IP Address to be used. (This is optional and your Service Provider can tell you if it needed, 
and also what it is, if necessary). 

! Enter your Login Id/Username (for SNPP Protocol connections) for this Service Provider route. Consult your 
Service Provider to find out if you need to enter a value here. 

! Enter your Password/PIN (for SNPP Protocol connections) for this Service Provider route. Consult your Service 
Provider to find out if you need to enter a value here. 
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When you have completed the route press the “OK” button 
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6.4.3.1.3 Serial Device Type 
 

To set up a serial route; 

 
 

• Select the connection to be used. The connection must have been defined first to appear in the list.  
• Select the protocol (this is TAP by default, but your service provider can tell you which protocol you should use). 
• Enter your password/PIN (for TAP protocol connections) for this service provider route. Consult your service 

provider to find out if you need to enter a value here. 
 

When you have completed the route press the “OK” button. 

 

6.5 Licensing 
 

By default the demonstration version of the system supports just one client and a predefined Evaluation period of 30 
days.  It is possible however to request from Connection software that the number of Evaluation users and/or the 
Evaluation period be extended should you require it. 

Licences can be purchased for additional or unlimited Client numbers from Connection Software or your supplier. 
Licence upgrades are transmitted directly to the server via the Infolink Receiver or can be supplied by telephone, 
email, fax, mail, etc. 

To view license details from the “Help” menu, select “About”, this will load a screen similar to 
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6.5.1 Requesting a license upgrade 
You can obtain a new License key from Connection Software, by Fax, Email, Phone or post. But before Connection 

Software can issue a new license you will need to create a License request file.  This license request file will 
contain all the information needed by Connection Software to produce the license key. 

To produce the license request file, from the “Help” menu select “Register”, this will load the following screen: 

 

You will need to specify the number of required users and the Network Details.  When you have finished entering 
the details press the “Save Licence Details” button.  This will load a directory-browsing dialog; select the 
location where the file will be saved and press “OK”.  This file can now be faxed, emailed or posted to 
Connection Software. 

If you wish to talk to someone at Connection Software about the license upgrade, please open the license request file 
in a text editor (such as notepad). 

6.5.2 Entering a new License key by hand 
Generally, when an upgrade to a license is performed, the new key is sent to the Server’s attached Infolink receiver 

and is processed automatically.  But, it is also possible to enter a new license key manually. 

If you do not have an InfoLink receiver in operation with the Server you can enter new license key details by 
selecting from the “Help” menu “Set License Key”, this will load the license key screen. 

 

Enter the new license key supplied by Connection Software and press “OK”. The new key will come into effect 
straight away. 
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Once the License has been upgraded you can view the new license details by selecting from the “Help” menu 
“About”; this will load a screen similar to 

 

 
 

6.6 Users 
After your system Licence has been upgraded to permit multiple users, you should add additional users.  As the 

System Manager you need to let other people use the system.   

You can configure the Server to match your organisations departmental structure very easily.  Specifying the 
departments will allow you to select which departments your users are in and also means you will be better able 
to set up departmental address books. 

To specify departments from the “Edit” menu select “Departments”, this will load the “Departments” list.  From this 
screen you will be able to Create, Modify and Delete department names. 

To view the User list, select from the “Edit” menu “Users”, this will then load the “Users” list screen.  From this 
screen you will be able to Create, Modify and Delete user details. 

To add new users see the section on Maintaining Users in the “Using the Messaging Server” portion of this manual. 

7 Using the Messaging Server 
This section of the Managers Guide is intended to show the different modules of the Messaging Server and how they 

function and work together. 

With the Messaging Server it is possible to view the history of Message requests that have been received and 
processed by the server and view the current activity of the Server itself. 

7.1 The Main Screen 
The Main Screen of the Messaging Server gives you access to the two main views; the “Messaging Output” view 

and the “System View”, as well as various configuration dialogs designed to tune the Server to your 
requirements.  
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7.1.1 Messaging Output 
 

This tab allows you to view the history of all the Message requests dealt with by the Server.  It is possible from this 
screen to see quickly whether a Message has been sent (or not) and if problems were encountered when sending 
a Message. 

 

In order to quckly identify the status of a Message the interface makes use of the following symbols 

 

 
The Message has been sent succesfully 

 
The Message has not been sent 

 
The Message failed, but is being retryed 
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7.1.2 System View 
This view allows you to monitor the current activity within the Server. From this screen you can see when a user logs 

into the System, the current status of devices, when a Message request has been received, and when a user has 
requested address book facilities.  The details displayed in the “System View” are also written to a text based log 
file, which is stored in the Server program directory, and is called paginsvr.log. 
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7.1.3 System Errors 
The System Errors screen displays errors, warnings, and informational messages pertaining to the system hardware 

or status, not related directly to messages being sent. This screen should be checked to verify the overall health 
of the system. 

 

 

7.1.4 Configuration Options 
The Server configuration options are: 

♦ Message Parameters 
♦ Drop Directory Location 
♦ Log Files Parameters 
♦ Infolink Receiver 
♦ Devices 
♦ Message Providers 
♦ Provider Routes 
♦ Departments 
♦ Users 
 
For the Server to achieve optimal operation, each of these items should be reviewed to see if the default settings are 

the most appropriate for your requirements.  The following table lists the menus through which these options 
can be reached and what section of the guide deals with each option. 

 

Option Menu Sub Menu Section in Guide 

Messaging Parameters File Options General Configuration Options 

Drop Directory Location File Options Drop Directory 

Log File Parameters File Options General Configuration Options 

Infolink Receiver File Options Configuring the Server for the Infolink Receiver 

Devices Edit Devices Configuring Output Routes 
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Service Providers Edit Providers Configuring Output Routes 

Provider Routes   Configuring Output Routes 

Departments Edit Device Maintaining Users 

Users Edit Users Maintaining Users 

 

7.2 Maintaining Users 
In order for the client application to be able to use the Message facilities offered by the Server, a User entry has to be 

created within the System. This also allows the system to track which client has requested a Message request 
and where to send a response when a Message request has completed. 

To view the current list the Users. Select the “Users” entry from the “Edit” menu.  This will then load the “Users” 
list screen.  

 

 

 

From this screen it is possible to Add, Modify and Delete user details. 

 

NOTE: The number of concurrent users is defined by the License you have. This also governs the number of users 
that can exist within the system.  If you wish to upgrade the number of concurrent users, please refer to the 
section on Licensing contained within this guide. 
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7.2.1 Adding a new user 
To add a new User press the “New” button, this will then load the “User Properties” screen. 

 

To create the details for a new user you will need to enter: 

 

♦ Their User Id, this needs to be their network logon id 
♦ Select the Access Level for the user 
♦ If they are to be set as a “Department Head” then you will need to specify the Department they are responsible 

for 
♦ If they are to have “User” access level you will need, in the Department list, to specify what departments they 

are a part of 
♦ Set their Message options 
 
When you have finished setting their details press the “OK” button.  This will now return to the main user list. 
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7.2.2 Modifying a user 
To modify existing user details, select the name of the user in the User list and press the “Properties” button; this will 

then load the “User Properties” screen. 

 

Make the required changes and then press “OK”.  These new details will then be saved to the Server database. 

7.2.3 Deleting a user 
To delete a user from the system, select their name in the User list and press the “Remove” button.  You will then be 

asked to confirm your choice. 
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7.3 General Configuration Options 
You can use the System Options to configure how the Server operates. These rules include how many log records 

can be stored within the system, the maximum size of a Message allowed by the system, and the location of the 
Drop directory. 

The general configuration options required by the Server can be reached by selecting from “Options” the “Edit” 
menu.  This will then load the following screen. 

 

7.4 Message Parameters 

7.4.1 Message 
This controls the parameters that will be used when a Message is being sent 

Messages 

Maximum Size The Maximum size of a Message that a client application can send 
Message Size The Maximum size of a Message that can be sent to a Mobile/Cell phone or 

Beeper/Pager 
Batching Szie If using dialup the number of Messages to hold before transmitting them. 

 

Retries 

Number of the number of retries that can be performed before reporting an error (0 to 20) 
Interval  the number of seconds to wait before attempting to retry again (0 to 600) 
Timeout on Send The length of time to wait before a timeout occurs (0 to 120) 

 

NOTE: If a Message exceeds the maximum allowed size for a Message, the server will split that Message into 
sections and send it as two separate Messages. 
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7.4.2 Log Files 
The Log Files section allows you to set how many records will exist within the system database.  This is important to 

ensure that logging does not exceed your disk-based storage. 

 

You can change the number of days of logging to be recorded here. This defaults to 4000. In order to avoid larger 
log files than is necessary  System Managers are strongly advised to consider the actual duration that logs need to be 
kept for and adjust this figure accordingly. Ignoring this will result in overly large log files which could impact your 
system performance uncecessarily. 
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7.4.3 Alarm Messaging 
Alarm Messaging allows a system administrator to configure the Server to alert a nominated recipient of any 

problems that occur during the operation. The recipient can be a Cellular/Mobile Phone, Bleeper/Pager, or a user 
of the System. 

 

To configure Alarm Messaging select the Alarm Tab, you will then see the following screen: 

 
 

On this screen you can  

! Select or enter a Destination Cellular/Mobile or Beeper/Pager number (and Service Provider to handle the 
sending) 

! Select the Nominated Users of the system that will be notified of any alarms that occur. 

! View and configure the Alarm message 

 

7.4.3.1 Specifying a Alarm Destination 
It is possible using the system to send an Alarm message to either a single cellphone/mobile phone or bleeper or 

pager, a Corporate contact in the address book or to a Rota Group.  

7.4.3.1.1 Sending to a cellphone/mobile phone or bleeper/pager 
To send an Alarm Message to a cellphone/mobile or bleeper/pager you will need to enter in the Destination field the 

Pager ID and then select the Service Provider of that cellphone/mobile or bleeper/pager. 

7.4.3.1.2 Sending to a Contact or Rota 
To select a contact or Rota, on the Alarm Messaging screen press the “To…” button, this will the load the contact list 

screen 



Client/Server Messaging System v3.28 - Server Manager's Guide  Page 30
  
Copyright © Connection Software 1999-2001  server_managers_guide.doc 

 
 

From this screen you will be able to select either an individual Corporate Contact or select the name of a Rota 
Group.  When you have selected the contact press the OK button and you will be returned to the Alarm 
Messaging Screen.  The name of the contact will then be displayed in the Destination field. 

 

7.4.3.2 Selecting users 
It is possible to send notification of an Alarm to a user of the System. 

To do this click the “Add” button, this will load the following screen. 

 

 
 

Select the names of the users that will be notified when an Alarm occurs and press the OK button.  The selected 
users will then be displayed in the Nominated Users list. 

To Remove a user from the list on the Alarm Messaging screen select the name of the user to be removed and press 
the “Remove” button. 

7.4.3.3 View and Configure Alarm Messages 
You can configure when and how frequent an Alarm Message should occur. 

To view the currently available Alarm Messages press the “Messages…” button on the Alarm Messaging screen. 
This will then load the list of available Alarms: 
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On this it is possible to  

! Enable / Disable an Alarm 

! Specify if an Alarm should be reply to 

! How many times an Alarm is allowed to occur before a message is sent 

! How long over time an Alarm is allowed to occur for 

! What the allowable memory resources are 

 

To view and modify the properties for an Alarm,  select the alarm you wish to view and press the “Properties…” 
button.  This will then load the Alarm Properties window.  When you have finished setting the values for an 
Alarm press the OK button to save the details. 

 

 
 

When you have finished configuring the Alarms in the System, when you press on on the Alarm Messages window, 
the system will automatically update the Alarming values so that they become effective immediately. 
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8 Address Book Exporting and Importing 
This section of the manual is intended to show how it is possible to export and import data to/from the address 

books. 

The Server currently supports exporting and importing of the following address books; 

 

Address Book Export Import 

All address books Yes No 

Corporate  Yes Yes 

Department Yes Yes 

Private Yes Yes 

 

8.1 Format of the Address Book Import/Export file 
Import/Export of the address books uses a Comma Separated Values (CSV) file. 

The format of this file is very specific: 

 
firstname,surname,subid,Pagertype,msgsize,provider,booktype 
Steve,Smith,2323,Alpha Numeric,12,Mercury Paging,Department book Servicing 
Pete,Purvis,780161,Alpha Numeric,240,Mercury Paging,Personnal book for scott 
Timothy,Cuningham,TimCun99,Alpha Numeric,240,PageOne Communication,Corporate 
 

The first line of the CSV file is the column titles of the fields.  These have been included to make it easier for you as 
a user to display or create this information in a third party application such as Microsoft Excel or Microsoft 
Access and are ignored by the Server. 

When you are importing data into the address books, the CSV file must start with column title line.  It is not 
necessary to include a column title entry for the address book booktype, but the first line must still contain 
the column name. 

If a field contains quotes it is possible to wrap that field in quotes e.g. 

firstname,surname,subid,pagertype,msgsize,provider,booktype 
“Steve”,”Smith”,2323,Alpha Numeric,12,Mercury Paging,Department book Servicing 
 

If a field does not contain a value then you must still include a column for that field e.g. 

firstname,surname,subid,pagertype,msgsize,provider,booktype 
Steve,Smith,2323,,,, 
 

You can see from this example that the line to be imported does not contain a pagertype,msgsize,provider 
or booktype.  For the first three fields that system will use default values and the forth field does not require a 
value.  But as you can see the field still exists. 
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8.2 Exporting data from the address books 
To export an address book, from the file menu select Address Book and then Export.  This will then load the export 

screen: 

 

 
 

You can choose to export any of the following address books 

♦ All contacts in all of the address books 
♦ The Corporate Address Book 
♦ A Departments Address Book 
♦ A Private Address book 
 

8.2.1 Exporting all Contacts 
To export all the contacts select in the “Select address book” field choose “All contacts” and then press the “Go” 

button.  The “Save As” dialog will be displayed to allow you to select the location to save the exported address 
book to. 
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8.2.2 Exporting the Corporate Address Book 
To export the Corporate contacts select in the “Select address book” field “Corporate” and then press the “Go” 

button.  The “Save As” dialog will be displayed to allow you to select the location to save the exported address 
book to. 

 

 
 

8.2.3 Exporting Department Contacts 
To export a Departments contacts select in the “Select address book” field “Department” and then select the name of 

the Department to export and press the “Go” button.  The “Save As” dialog will then be displayed to allow you 
to select the location to save the exported address book to. 
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8.2.4 Export User Contacts 
To export a Users contacts select in the “Select address book” field “User” and then select the name of the user to 

export and press the “Go” button.  The “Save As” dialog will be displayed to allow you to select the location to 
save the exported address book to. 
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8.3 Importing data to the address books 
To Import data into an address book from CSV file, from the file menu select Address Book and then Import.  This 

will then load the export screen. 

 

 
 

From this screen it is possible to import data into the following address books 

♦ The Corporate address book 
♦ A Departments address book 
♦ A Private address book 
 

8.3.1 Importing into the Corporate Address Book 
To import into the Corporate address book select in the “Select address book” field “Corporate” and press the “Go” 

button.  The “Open” dialog will be displayed, use this screen to select the file to import. 
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8.3.2 Importing into a Departments address book 
To import into a Departments address book select in the “Select address book” field “Department” and then select 

the name of the Department to import to and press the “Go” button.  The “Open” dialog will be displayed, use 
this screen to select the file to import. 

 

 
 

8.3.3 Importing into a Users address book 
To import into a Users address book select in the “Select address book” field “User” and then select the name of the 

User to import to and press the “Go” button.  The “Open” dialog will be displayed, use this screen to select the 
file to import. 
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9 Client Installation 

9.1 Installing and Configuring the Messaging Client Software 
For installation of the Client software, the reader is referred to the Installation Guide. This gives complete 

instructions on how to install and configure the software.   
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10 Log File Format 
Log files and drop files share essentially a common file format with more/less fields. 

The log file format is as follows. Each attempted connection to a Service Provider is recorded as a single line of text 
consisting of seventeen fields, each separated by a “|” (pipe) symbol. Several of the fields are currently unused 
and are reserved for future expansion.   

An example entry might be: 

19990129|000000||scott|839437|||||||||||This is a test Message|Fred Smith 
 
YYYYMMDD|HHMMSS|<server name>|<From>|<To>|<Service Provider 
Number>|<Transport Code>|<Protocol Code>|<Success/Failure Code>|<Success 
Failure Message>|<Unused>|<Unused>|<Unused>|<Unused>|<Unused>|<Message>|<User 
Signature> 
 
Field Number Contents Explanation 

1 YYYYMMDD The date of the attempted connection 
2 HHMMSS The time of the attempted connection 
3 <server name> Name of the Server that made the 

connection (currently blank) 
4 From The login name of the person the 

Message is from (currently a number) 
5 To The Subscriber Number of the person to 

whom the Message is to be sent 
(typically 6 to 11 digits). 

6 Service Provider 
Number 

e.g. 1=PageOne Communications 

7 Transport Code e.g. 1=dial-up 
8 Protocol Code e.g. 1=TAP 
9 Success/Failure code e.g. 0 
10 Success/Failure 

message 
e.g. Message Accepted 

11 Reserved  
12 Reserved  
13 Reserved  
14 Reserved  
15 Reserved  
16 Message The Message to be sent 
17 User Signature The user signature to be attached to 

the Message 
 

11 Drop Files 
You can “drop” a text file into a specified directory and the Server will automatically “collect” it. The file will be 

read and (assuming the format is correct) the message in the file will be transmitted. 

11.1.1 Default Drop Directory 
The default Drop Directory is 

 
C:\<WINDOWS DIRECTORY>\Profiles\admin\drop 
 

11.1.2 Drop File Filename 
Any file with a .pag or .page extension will be read from the Drop Directory.  



Client/Server Messaging System v3.28 - Server Manager's Guide  Page 40
  
Copyright © Connection Software 1999-2001  server_managers_guide.doc 

11.1.3 Drop File Format 
All files that are dropped into the directory must currently have exactly this format: a single line of text consisting of 

16 fields each separated by a “|” symbol. Several of the fields are currently unused and are left for future 
expansion.  Here is a sample Drop File 

 
19990129|000000||scott|839437|Provider|||||Y||||This is a test page|Fred Smith 
 
YYYYMMDD|HHMMSS|<reserved>|<User Name>|<To>|<Service Provider 
Name>|<Reserved>|<Reserved>|<Reserved>|<Reserved>|<Reply 
Requested>|<Reserved>|<Reserved>|<Reserved>| 
 

Field Contents Explanation 

1 YYYYMMDD The earliest date that the Page can be sent. 8 numbers are 
required. Any separating characters will be ignored. Thus all 
the following are acceptable: 

19981202, 1998-12-02, 1998/12/02 

None of these are acceptable:  

1998/12/2, 2 December 1998 

2 HHMMSS The earliest time, on the above date, that the Page can be sent. 
6 numbers are required. Any separating punctuation 
characters will be ignored. Thus 11:28:00 is acceptable 

3 <Reserved> Reserved for future use. 

4 User Name The login name of the person the Message is from 

5 To The Subscriber Number or Callsign of the person to whom 
the Message is to be sent (typically 6 to 11 digits). 

6 Service Provider Name The name of the Provider to be used to send the page.  Can be 
empty. (If the provider is not found in system database the 
default provider will be used). 

7 <Reserved> Reserved for future use. 

8 <Reserved> Reserved for future use. 

9 <Reserved> Reserved for future use. 

10 <Reserved> Reserved for future use. 

11 Reply Requested Is the page a reply request page.  To set reply requested set 
field to Y.  If left blank or N is placed in field page will not 
be reply requested. 

12 <Reserved> Reserved for future use. 

13 <Reserved> Reserved for future use. 

14 <Reserved> Reserved for future use. 

15 Message The text or numeric message to be sent. 

16 User Signature The user signature to be attached to the page 

 

Note that you can only send numeric messages to Numeric Pagers. If you attempt to send an alphanumeric message 
to a Numeric Pager then the message will be lost. The page must not contain any “|” characters or characters that 
the recipients device cannot display.  

11.1.4 Permitted Characters 
This is a guide to the characters known to be displayable on most pagers. Obviously, pagers vary and this is just a 

guide.  
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Pager Type Permitted characters 

Tone pager:  None 

Numeric Pager: 1,2,3,4,5,6,7,8,9,0,-,U,[,] 

Alphanumeric Pager: ASCII codes 32 (space) to 126 (~) i.e. all printable characters. 

 

If you are unsure, consult the recipient first or stick to the basic character and punctuation set. 

11.1.5 Caveats 
Messages are silently truncated as necessary. 
No acknowledgement is provided. 
Reply Requested is not supported for dropped-file messages. 
Each file must contain only one Message. 
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12 Support 
Connection Software will be glad to support System Managers if they encounter problems using this Messaging 

Server/Client system.  However, if you are using the PageLinkII brand of this software you must contact 
PageOne. 

 

We will also do our best to support those evaluating the system in single user mode and again we refer all 
PageLinkII customers to PageOne. 

 

Licence Upgrades are also dealt with by Connection Software or PageOne as appropriate. 

 

Please contact us by any of the following means: 

Post: Support 
Connection Software 
391 City Road 
LONDON 
EC1V 1NE 
UK 

Telephone: 020 7713 8000 
+44 20 7713 8000 

Fax: 020 7713 8001 
+44 20 7713 8001 

Email: support@csoft.co.uk 

It will help us to offer you a faster service if you can quote your Customer Number when contacting us. 



Client/Server Messaging System v3.28 - Server Manager's Guide  Page 43
  
Copyright © Connection Software 1999-2001  server_managers_guide.doc 

13 Feedback Form 
 
We have made every effort to provide the support that you may need in this Help file but we do want to hear about 
problems, and suggestions for improvements. All messages will be carefully analyzed and provide important input into 
future planning. 
 
If you would like to provide feedback then please mail, fax or email the appropriate form in the feedback document 
back to Connection software. 
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